Inline photos from Non-Secure sites

Post problems, suggestions, and site related questions here.
Post Reply
User avatar
Del
Jedi Aspirant
Jedi Aspirant
Posts: 734
Joined: March 21st, 2013, 12:46 am
Location: Lawton, OK
Contact:

Inline photos from Non-Secure sites

Post by Del » June 16th, 2021, 4:12 am

Not sure how to fix the problem, but my photos no longer work and I haven't changed anything on my end. This also happened at AllScaleTrek and they were able to correct the problem manually. It appears that an update to the phpBB software turns off the ability to display links for photos from non-secure sites. Here's a prime example -

Image

It should be displaying the retail label for my V-Wing kit, using the IMG tags around this link - http://www.mvmodels.biz/_kesselrun/vwin ... el_800.png

I can still post the link, but it won't display the image if I use the tags because it's from a standard non-secure website. I don't feel the need to change everything on my end to a secure site because the shopping cart is secure, just not the main website.

Not sure if this is something you can or want to fix. Just thought you should know in case you're wondering why all of my posts with photos show broken links. Thanks in advance for checking into this. ;)

--Del
Multi-Verse Models - http://www.mvmodels.biz or find me on Facebook
Retail sales of kits from Design Anomaly, Kessel Run Kits, NorthTrek Creations, Alternate Paradigms, and more!

monsterpartyhat
Youngling
Youngling
Posts: 16
Joined: May 10th, 2016, 6:46 pm

Re: Inline photos from Non-Secure sites

Post by monsterpartyhat » June 23rd, 2021, 1:27 am

It's not a phpBB issue - your image tag is translating to an <IMG> tag in the HTML just fine; it's a browser issue -- browsers won't load an image on a plain http connection when the site that the image tag is embedded in is on https. Even though you've used an http:// link for your image, Chrome is going to request it over https because keeperoftheforce is on https.

User avatar
Del
Jedi Aspirant
Jedi Aspirant
Posts: 734
Joined: March 21st, 2013, 12:46 am
Location: Lawton, OK
Contact:

Re: Inline photos from Non-Secure sites

Post by Del » June 24th, 2021, 4:39 am

monsterpartyhat wrote:
June 23rd, 2021, 1:27 am
It's not a phpBB issue - your image tag is translating to an <IMG> tag in the HTML just fine; it's a browser issue -- browsers won't load an image on a plain http connection when the site that the image tag is embedded in is on https. Even though you've used an http:// link for your image, Chrome is going to request it over https because keeperoftheforce is on https.
No, it's as I stated that the phpBB will not allow the inline photo to be viewed, although the link works just fine. The problem also occurred at AllScaleTrek and they fixed it - on the server side, not the client side. Once the hosting company figured it out, it was as simple as flipping a switch or something. At the time, it wasn't a problem at Starship Modeler, but by now I'm not sure.
Multi-Verse Models - http://www.mvmodels.biz or find me on Facebook
Retail sales of kits from Design Anomaly, Kessel Run Kits, NorthTrek Creations, Alternate Paradigms, and more!

User avatar
Uwe Kaeding
Jedi Aspirant
Jedi Aspirant
Posts: 584
Joined: April 9th, 2013, 12:06 pm
Location: Adelaide, Australia

Re: Inline photos from Non-Secure sites

Post by Uwe Kaeding » July 10th, 2021, 3:44 pm

Del - not sure what your issue is, as I don't have photos on a site to link to. However I can still upload photos from my computer. That should still work for you - you just might be limited to 10 photos per post.

User avatar
Del
Jedi Aspirant
Jedi Aspirant
Posts: 734
Joined: March 21st, 2013, 12:46 am
Location: Lawton, OK
Contact:

Re: Inline photos from Non-Secure sites

Post by Del » July 11th, 2021, 12:45 am

Uwe Kaeding wrote:
July 10th, 2021, 3:44 pm
Del - not sure what your issue is, as I don't have photos on a site to link to. However I can still upload photos from my computer. That should still work for you - you just might be limited to 10 photos per post.

I've never done that as I don't like to waste the resources of the forums. If they're already being hosted on my site why post them again. However, if I do this, would the photos be as attachments? Also, this won't fix all of my previous posts unless I go back and manually change every one where I have an image posted from my website folders. Thanks for the info though. ;)
Multi-Verse Models - http://www.mvmodels.biz or find me on Facebook
Retail sales of kits from Design Anomaly, Kessel Run Kits, NorthTrek Creations, Alternate Paradigms, and more!

User avatar
Uwe Kaeding
Jedi Aspirant
Jedi Aspirant
Posts: 584
Joined: April 9th, 2013, 12:06 pm
Location: Adelaide, Australia

Re: Inline photos from Non-Secure sites

Post by Uwe Kaeding » July 11th, 2021, 1:37 am

Del wrote:
July 11th, 2021, 12:45 am
I've never done that as I don't like to waste the resources of the forums. If they're already being hosted on my site why post them again. However, if I do this, would the photos be as attachments? Also, this won't fix all of my previous posts unless I go back and manually change every one where I have an image posted from my website folders. Thanks for the info though. ;)
Agreed about the resources - but if its the only way, its the only way! In any case I keep the size of the photos as small as I can, while still making them look OK. The photos get embedded in the post, not as attachments. Also it might be worth sending Chris a PM to see if he can figure out what's going wrong for you.

Post Reply